사용자 프로파일 변경해도 매크로 언어가 변경되지 않는 경우

  • System add-on 탭의 Gadget Plugin Disable / Enable

eazybi Add-on 계정 생성 오류 관련

  • When you will save eazyBI settings then a database connection will be established and a database will be created. Later when additional eazyBI accounts will be created then each account data will be stored in separate databases with names eazybi_jira_dwh_N where N is the account ID number.
  • DB에서 다음 쿼리를 통해 eazybi_jira 계정이 eazybi_jira_dwh로 시작되는 모든 스키마를 생성할 수 있도록 권한을 부여
  • grant all privileges on `eazybi_jira\_%`.* to `eazybi_jira`@`%` identified by ‘eazybi_jira’;

  • eazybi에서 eazybi 계정을 생성할 때마다 eazybi_jira_dwh_1부터 순차적으로 스키마가 생성되며, 계정 삭제 시 지워짐

Jira 복원 후 깨짐 현상 관련

AWS Confluence 접속오류 관련

  • Jira에서 계정을 가져올 시 EC2문제의 Rollback 과정에서 IP가 변경됨에 따라 연결이 끊어짐이 원인
    • Jira의 다음 메뉴에서 변경된 IP 추가
      • Jira Administration - User management - Jira User Server
    • Confluence Internal Admin 권한 복원
    • Confluence의 다음 메뉴에서 Jira Directory sync
      • Confluence Administration - User Directory

AWS EC2 Kernel Upgrade 후 OS reboot현상 관련

  • 타 회사의 JAVA Application을 테스트로 실행 시 동일 현상 재현(Atlassian솔루션이 원인이 아님)
  • 같은 버전으로 패치된 SVN이 있는 타 인스턴스에서 Jenkins 실행 시 동일 현상 재현(해당 커널 버전이 원인일 가능성이 높음)
  • WAS 서버의 커널 버전 업그레이드(3.13.0.135 Generic -> 3.13.0.155 Low latency)후 Jira 또는 Confluence 기동 시 서버가 Reboot되는 현상 (OS버전은 14.04.5 LTS로 동일)
  • AMI를 통해 이전버전으로 Rollback 후 문제되는 인스턴스에서 추가로 테스트 진행
  • 해당 커널 버전에서 JAVA를 사용하는 Application 기동 시 문제가 있는 버그로 확인 및 3.13 .0.160로 업그레이드

Confluence 6.12 Edit Office(Companion)문제

  • Edit Office 대신 새로 도입된 Companion 기능 사용 시 문제 발생
  • SSO가 설정된 상태에서 Confluence내에서 직접 edit office 작업 수행 시 파일이 corrupted되는 현상
  • workaround로 임시로 Goedit add-on 사용
  • 20181108현재 6.12.2 버전이 7일에 릴리즈 되었으며 업그레이드 시 해결되는지 테스트 필요

Jira / Confluence Comment에서 파일 업로드 시 text mode로 링크가 깨져서 보이는 현상

  • Mac OS의 Safari / Firefox등에서 발생하는 것으로 파악 및 Chrome 사용 시 해결

ETC

  • OracleJDK 유료화 관련
    • 2019년 1월 유료화전까지 OpenJDK를 지원하는 새 버전을 릴리즈할 예정이며, 해당 버전 릴리즈 시 Jira / Confluence 모두 최신으로 업그레이드 필요
    • 버전 업그레이드를 원하지 않을 시 OracleJDK라이선스 구매 필요
  • Enterprise Release 지원 여부
  • 설계부터 rework되기 때문에 현 Enterprise release 버전(Jira 7.6 / Confluence 6.6)도 최신으로 업그레이드 필요
    • Currently, we are only planning to release JIRA 7.13 and JIRA 8 which supports OpenJDK. You may find information about JIRA 8 support for OpenJDK in the documentation below:

    • Preparing for Jira 8.0

    • We do not have a plan to release newer lower of JIRA which support OpenJDK (including JIRA 7.6.X). This is mainly because supporting OpenJDK does require significant rework within JIRA as well as the plugins and we are focusing on rework in the newer version of JIRA. You would need to upgrade to the latest JIRA once it available to get support while using OpenJDK.

    • Confluence 6.6 Enterprise release will not be supported for OpenJDK as a lot of things need to be reworked to fit use that JDK. Yes, you will need to upgrade of 6.13. From what I heard, is that 6.13 will be enterprise release as well.

kjeon's profile image

kjeon

2018-11-08

Read more posts by this author